Issues With Helpdesk Emails

Incident Report for Capacity

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 15:34 CDT

Monitoring

Services have been restored and inbound emails should now be making their way to the Helpdesk. We will continue to monitor.
Posted Mar 13, 2026 - 09:40 CDT

Investigating

We are currently investigating an issue with our email services - inbound emails are currently not being delivered to the Helpdesk, our team is actively working to get to the bottom of the issue.
Posted Mar 13, 2026 - 09:25 CDT
This incident affected: Helpdesk.