Mailgun experiencing delays in processing emails

Incident Report for Capacity

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 17:51 CST

Monitoring

Our third party provider Mailgun has been experiencing some delays in processing emails. Events are beginning to process normally now and there will be a longer than usual delay in tickets hitting your Helpdesk. We will continue to monitor this.
Posted Nov 28, 2025 - 10:42 CST
This incident affected: Helpdesk.