Failed Attachments

Incident Report for Capacity

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 11:07 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 11:31 CDT

Identified

We are aware of an issue related to Attachments and many users receiving Failed Attachment notifications, our engineering team has identified the issue and are working on a fix.
Posted Apr 17, 2026 - 10:58 CDT
This incident affected: Helpdesk.