Intermittent Helpdesk Issue

Incident Report for Capacity

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 11:30 CST

Monitoring

Capacity's mail service seems to have recovered, and we are closely monitoring.
Posted Nov 13, 2025 - 10:48 CST

Identified

Capacity's email service provider has reported an incident resulting in intermittent bounce backs for their email service. We are closely monitoring.
Posted Nov 13, 2025 - 10:31 CST
This incident affected: Helpdesk and mailgun Inbound email processing.